Catalina Mac Compatibility

Posted by

Apple has released a list of Macs that are compatible with the new Catalina 10.15 OS. To my surprise my old Late 2012 iMac can run it. I think that has something to do with the “Metal” feature built into the Logic Board architecture. At any rate, if you are wondering about your Mac, check out the Catalina compatibility list right here.

Doug

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.